Workspace switching not working in Win11


I’m a new user of UHK, just unpacked it and went through the tutorial. I am impressed with the layer functionality! I’m still trying to adapt to the slightly changed positioning of the keys (I’m coming from a Keychron keyboard). Sadly, I’m already having an issue – like the subject says, the default workspace switching mapping doesn’t work on my system. It should send the Left Ctrl + Left Alt + arrow combination. But when I press Mod+F or Mod+S nothing happens. I tried checking with some online keyboard testers and it seems to be OK. The key combination used to work on my old Keychron keyboard. I normally use Windows 11 with English language and a Polish programmers layout (GrAlt is used to enter accented characters), but I switched to US and US International layouts briefly and it did not change anything. I’m on the newest firmware (updated right after setting up the keyboard). Do you have any tips on how to troubleshoot this issue? I use that shortuct A LOT, it’s one of the most often used Windows shortcuts for me. I can’t live without it :slight_smile:


Windows+Ctrl+Left or Right Arrow: Switch between virtual desktops

is working flawless for me, even though my arrow keys are on the mod-layer

Have a nice day.

1 Like

Hm. I’m dumbfounded, to be honest. :slight_smile: The UHK tutorial says Mod+S and Mod+F are for workspace switching and the default mapping looked alright to me. Maybe it always was Win+Ctrl and not Ctrl+Alt. I honestly am not sure what keys I’ve been pressing, it’s all muscle memory. You are right, the combination with the Win key works. I’m going to re-map the shortcut in Agent, let’s see…

1 Like

Yup, it works now! I feel a bit stupid right now. Thank you @Makami !

1 Like

Don’t worry, I do know that feeling, but that’s the reason, we’re humans and not robots!

You might like to fool around with GitHub - microsoft/PowerToys: Windows system utilities to maximize productivity - Keyboard Manager for any keyboard for having to press less keys.