Speed modifiers for touchpad

Hello!

Using the mouse button / keyboard to move the pointer has the added benefit of making mod/fn act as modifiers button increasing / decreasing the pointer speed whilst depressed.

Can I do the same thing when using the touchpad? I would imagine it’s possible but didn’t find a trick to achieve this yet.

Thank you.

Have you tried it? The mouse key accelerate / decelerate modifiers should affect the touchpad too.

Whilst using the touchpad, mod switches to scroll mode and fn switches to caret control mode.

I cleared out my onInit to rule that out. Then I reset the device config. Hence the question. Does it behave differently for others?

Couldn’t you create some macros (and bind them to keys) that change the speed and acceleration settings for the touchpad? I’m away from my UHK at the moment and can’t try it out.

Yes, I’m sure I could do that… but I cannot do it for the Mod key alone and have it work in the same way as it does for controlling the pointer with the mouse key. Do you know what I mean?

No, I don’t really understand what you mean. Can you give examples of what you want your key combinations to do?

When using the touchpad, I would like to have modified keys (mod and fn) to modify the speed of the touchpad cursor just the same as these keys behave when control the speed of the mouse using the mouse button / keyboard.

If I understand correctly that you want a key to act as a (hold) layer switcher and mouse key acceleration modifier at the same time, then the following macro should do the job:

startMouse accelerate
holdLayer mod
stopMouse accelerate

Otherwise, please elaborate on what it is that you want.

I’m sorry that I’m failing so badly to accurately explain myself!

Yes, I think you’ve got it EXCEPT I’d like that acceleration to accelerate the mouse cursor when using the touchpad. In exactly the same way that the default behaviour of mod does this for the mouse layer. So desired outcome is:

Mod button IS NOT depressed: Touchpad mouse speed is normal
Mod button IS depressed: Touchpad mouse is very fast.

That macro should accelerate the touchpad.

If that is not working for you, then please post your firmware version and attach your UserConfig, and I will give it a try.

I hate to trouble you but equally curious if this is possible.

Figured I might need to disable something in my init macro, namely this:

set module.touchpad.navigationMode.mod scroll

Alas, no.

My config here, macro is named Karel's Macro, mapped to the mod key. Cheers.

Well, when your navigation mode is set to scroll on mod layer, of course that macro is going to scroll (at accelerated speed).

When I add set module.touchpad.navigationMode.mod cursor it works just fine. I.e., when the macro is pressed, cursor moves at twice the normal speed.

Edit: If you want to preserve the navigation mode for mod layer (because of other layer switchers), you can change the navigation mode directly in the macro. E.g.:

set module.touchpad.navigationMode.mod cursor
startMouse accelerate
holdLayer mod
stopMouse accelerate
set module.touchpad.navigationMode.mod scroll

Wow. Cursor was the answer. Changing navigation mode also works flawlessly. You’ve answered my question.

Super grateful, Karel. Thanks a lot.