[Solved]Firmware 10.4.0 - A Macro Problem

After upgrading to the new firmware 10.4.0, the following yellow message appeared

Error in $onInit 1/6/21: Unrecognized command: invertScrollDirection

6 | set module.touchpad.invertScrollDirection 1

The error message appeared even though I had options for the “set >> module scroll direction.”

That config value was removed in favor of per-axis configuration.

This now corresponds to:

set module.touchpad.invertScrollDirectionX 0
set module.touchpad.invertScrollDirectionY 1
1 Like

Thank you!!! This worked for me correctly.

1 Like

@kareltucek How about providing explicit error message for migration purposes in this case?

Yeah, I think it was mistake to remove the code including deprecations… So what about returning all the deprecation warnings present in 10.2.? (I.e., not just this one feature.)

I can’t recall the deprecation warnings that were present in firmware 10.2.*, but as a general rule, explicit migration instructions are always useful.

The docs inside the agent currently do not show this new change either.
There it still persists as invertScrollDirection see screenshot.

Agent Version: 3.2.1
Firmware Version: 4.2.0
UHK v1 & UHK v2

1 Like

Thanks for the heads-up! Just fixed it, and the fix will be live in Agent via the next firmware version.

1 Like