Completely disable taps on the touchpad

I have both the key cluster and the touchpad module, and I’m probably using the touchpad in a weird way but I get a lot of ghost taps and drags when I’m using it just to move the cursor around.

I’d be ok in using the click buttons in the key cluster module, disabling all the tap actions in the touchpad, but I haven’t found a way to do that. I haven’t probably searched hard enough. Any pointers?

That sounds like a malfunctioning touchpad to me.

You can easily unmap the single-finger tap in Agent:

(If you run into problems with other gestures (double finger “right-button” tap, scroll gesture or zoom gesture), they can be disabled via smart macros…)

The ghost taps might be resolved by fastening module screws.

One thing I am noticing with the touchpad is that if I point to somewhere and don’t let go of the touch (imagine I am reading something on the page and forgot to lift my touch finger up), it converts into a (left click+ touch) action. is there a way I can avoid that? (Does it make sense what I am trying to convey? :joy: )

Given that drag and drop can be initiated by touching and holding finger in place for a short interval and just then moving, I guess your touchpad is either loosing connection from time to time, or you are actually releasing the finger (if touching the touchpad very lightly.).

Please try to fasten your touchpad module’s screws as suggested above that may resolve this issue.

I tried fastening the screws, but I still get taps detected when I really didn’t want to tap. Like I’m moving the cursors hover a web page and end up with random portions of it selected.

Does the I2cRecovery counter keep incrementing when these issues happen?

No, it’s stable at 0. I’m inclined to think it’s a me problem, I just use the touchpad in a way that’s triggering taps when I don’t want to.

By the way, I removed the click action for the touchpad in the Agent, and somehow I managed to still get this select text thing while trying it out on a web page. I haven’t found a reliable way to reproduce this yet unfortunately.

We haven’t heard about this issue yet, but please keep us posted, and we’ll do our best to figure it out.