Can't seem to get Shift+F6 to work?

I’m trying to achieve what on a standard keyboard would be Shift+F6. I’m mapped the 6 key on my Fn layer to F6. However, the combination of Shift+F6 simply gives me the ^ symbol, as if Fn where not being pressed.

If I read this correctly, you have mapped Fn-6 to F6. Are you then pressing Fn-Shift-6 on the keyboard? You should be getting a Shift+F6 keypress sent to the computer.

Thank you for the reply, yes – here is the mapping (below), and here is me pressing FN+Shft+6, ^^^^^^;

Given that you press fn+shift+6 rather than shift+fn+6, does your fn layer contain shift mapping?

Thank you for the response. If I turn on shift mapping, I start with all blank keys – meaning that I would have to map all my standard shift keys – which would be a bit of a pain.

I don’t suggest to use the shift layer. I say that if you use the shift key in your fn layer and expect it to produce shift, the key has actually to be mapepd to shift in your fn layer.

(Also, blank keys in modifier layers fall through to base layer, but that is irrelevant now.)

I would normally push this statement to another thread, but it may be related to my problem? If I turn on the shift-layer, my shift key stops working.

May it? I am more confused with every post! :slight_smile:

Oh, I see, maybe, please upgrade to latest firmware… there was a bug that caused bad function of modifier layers…

Hmm … I’m not entirely sure that means? Is my mapping potentially done wrong?


Ahh – thank you. I’ll try that now.

Please, post screenshot of your entire fn layer :-).

Thank you, I did - above - but maybe it wasn’t obvious that was all that was mapped. Here we go;

Right. I mean that that wide key in left bottom corner of your screenshot has to read shift.

I feel silly now – thanks for your patience;

Change is made as below, saved to keyboard, but still doesn’t seem to have changed the operation.

Dear goodness, I think I see the issue now. Somehow FN is not mapped on my base layer – I am an idiot.

That fixed it, so sorry to have wasted everyone’s time. Thank you for the help.

No problem!

Glad it works now!