Cannot detect new v6 UHK after Agent upgrade

I got my new UHK to replace my v1 today, and it looks and feels great. However, it didn’t have the few key customizations from my previous keyboard. I launched Agent, and it offered to flash a new firmware. It found an Agent update just before I could click the button, so I downloaded and installed that. After relaunching, the Agent cannot find my new keyboard anymore.

The keyboard works, but it’s using the default configuration. Any idea how to solve this? I have a lot of saved state in my session (active dev work) so was hoping to put off a restart, and it did detect it before updating Agent. Can (should?) I downgrade the Agent software?


So you are using old firmware and new agent?

Try downloading an old agent, use it to flash a new firmware (you can download that at Releases · UltimateHackingKeyboard/firmware · GitHub).

Ideally backup your configuration somewhere in the process.

When you are on new firmware and new agent, you should be able to recover your configuration either from a manual backup or from the history on the configuration tab of the agent.

I’m wary of bricking my new UHK, so here’s the timeline.

  1. Got a v1 UHK many years ago.
  2. Updated Agent and its firmware to the latest sometime in the past couple of months.
  3. Got a v6 UHK yesterday.
  4. Swapped keyboards.
  5. Launched Agent.
  6. It detected the new keyboard.
  7. Was offered to update the firmware on the v6, but before I could…
  8. Was offered to download a new Agent, which I did to be safe.
  9. Relaunched Agent.
  10. Keyboard not detected. :frowning:

To be clear, the keyboard works completely using the factory firmware: typing, putting the PC to sleep and waking it up, the backlighting, the mod layers, etc.

No doubt downgrading Agent is the play, but I’m wary since I would expect the latest UHK version would more likely require the latest Agent. I ordered this keyboard just over two weeks ago.

Edit: I’m on Ubuntu 20.04. Is there a way to see which version of Agent I had previously so I can download the same version?

Does any of the above change your advice to downgrade Agent and flash the firmware?

Thanks for your help, and happy new year.

If your UHK is operational, and it is, you haven’t bricked it.

You can also connect your UHK via other USB ports and without KVM switches, docking stations, and USB hubs.

Using Agent on another computer can also be useful to figure this out.

I downloaded Agent 3.2.1, and it was able to see my new UHK. I flashed the firmware, made my few config changes, saved to the UHK, and everything is working great.

I then updated to 3.2.2 (using the Agent and downloading the image in Chrome), and it fails to see my UHK. I reinstalled 3.2.1 again, and it sees it. Does the Agent need an update to see UHK v6?

In any case, my problem is resolved. Thanks so much for your help. Cheers!

Thanks for your follow-up, and I’m glad the problem got solved!

However, the problem is not fully solved yet because Agent 3.2.2 and possibly later versions will be affected on your side. Would you open a new Agent issue, so we’d look into it?

Just to clarify, you have a UHK 60 v2, not v6, so that my colleague won’t get confused when reading your report. :slight_smile:


I assumed it was v6 because the getting started URL was /6. Oops. :slight_smile:

1 Like